Login failed for user ‘IIS APPPOOLClassic .NET AppPool’

Have you just installed Windows 7 or Windows Server 2008 R2 and when you tried to setup your asp.net/mssql website you got following error: “Login failed for user ‘IIS APPPOOLClassic .NET AppPool‘”?

It seems that new IIS version 7.5 runs its Classic .NET AppPool process with a different identity, and from there we get error “Login failed for user ‘IIS APPPOOLClassic .NET AppPool‘”.

Solution

Information Services (IIS) Manager

  • go into Internet Information Services (IIS) Manager
  • expand node with your computer name on left side and select “Application Pools”
  • now in the window on the right side, right click “Classic .NET AppPool” and select “Advanced Settings…”

Change Identity property to LocalSystem

  • find “Identity” property and change its value to “LocalSystem”

45 thoughts on “Login failed for user ‘IIS APPPOOLClassic .NET AppPool’

  1. Thank you. Really so wounderfull and easy way help . Like it so much. Keep it up and continue with more help to the human being.

  2. Sweet, thanks! First google hit too, saved me tons of time! At first I thought my export/import of logins from SQL Server A to SQL Server B goofed. Nope, it was just this setting.

  3. Heya i’m for the primary time here. I came across this board and I in finding It really helpful & it helped me out much. I’m hoping to provide something back and help others like you aided me. wypo

  4. We’re a bunch of volunteers and opening a new scheme in our community.
    Your web site provided us with helpful info to work on.
    You’ve done an impressive task and our whole community will probably be thankful to you.

Leave a Reply

Your email address will not be published.